Green Tractor Talk banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2,055 Posts
Discussion Starter · #1 ·
Hiya,

So, I have a Speeco splitter that has an open center valve that I have run off other power beyond setups on other Deere tractors. These other tractors had a single PB connector and I would place the splitter valve in-line on the circuit and all was well. As you may know, the PB on the 3x20 series has an additional connector that you affix the return hose to instead of the disconnected hose end.

My issue is that when I connect the hoses of the splitter as Deere says, the rockshaft appears to be out of the hyd circuit and will not lift the splitter. This is a PITA as I have to keep connecting and disconnecting hoses.

My question, understanding that I have an open center valve on the splitter, would it be possible to place the splitter in-line on the PB circuit, NOT connecting to the additional port (what I suspect is a simple dump port) and not damage the pump by causing a deadhead?

Tom
 

·
Administrator
Joined
·
23,173 Posts
Yes Tom, the new "extra" port is directed directly to the tank bypassing the 3PH since its not needed or wanted wanted when the backhoe is mounted. All you need to do is connect the splitter into the "Loop" that is created when the backhoe is NOT mounted.

Clear as mud?

FYI: I also moved this to the hydraulic forum as well.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top