Green Tractor Talk banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 20+ year old STX38 which has been working well with the exception of a problem that cropped up the other week. The PTO for the mower deck would kick in but would disengage after a short period. Upon inspecting the electrical connection to the PTO. I took it to a local shop and he said it was just the wired connection at the PTO. The plastic clip had burned thru and the metal clip itself was damaged from heat. He replaced the clip and connector and when i got it home it worked fine for an hour or 2. Looking at the PTO again I see that it has happened again pretty much identical to before. Any suggestions?
 

·
Registered
Joined
·
1,751 Posts
PTO clutch is likely drawing too much current. If a current draw test confirms this then the clutch needs to be replaced and plug fixed again.

Sent from my LGL52VL using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
PTO clutch is likely drawing too much current. If a current draw test confirms this then the clutch needs to be replaced and plug fixed again.

Sent from my LGL52VL using Tapatalk

Thanks for your speedy reply. Had to get a new multimeter as old one was fried and found the pto is drawing between 3 and 4 amps which I understand is ok. Plugged it back in minus the melted clip for a brief cut. ( The melting of the clip had disconnected the PTO ).Worked ok and no discerable heat damage observed so I guess I will take it easy on the mower and see how it goes. Thanks again, I'm quite clueless when it comes to electrical problems.
 

·
Registered
Joined
·
41 Posts
Tom I'm in the same boat with STX38 electrical problems, I'm going to have to rewire most of the tractor. Since you have the same tractor would you care to take a picture of the wiring off of your battery? I'm trying to figure out what the purple wires coming off of the harness connect to


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4,571 Posts
The PTO on the STX38 isn't adjustable? I just picked one up the other day. I haven't looked at it yet. I got it more for the rear tires than anything else.
 

·
Registered
Joined
·
9 Posts
STX38 PTO Clutch

Hey gang - this thread seems a bit like my issues. I have a STX38 black deck and my PTO clutch stopped working. i found the PTO switch to be bad so i replaced that. I started the mower, engaged the PTO switch and it engaged the mower deck. It ran great - for about 5 minutes then the PTO quite again. I turned the PTO switch off and back on and it pulled pulled apart. The knob pulled out of the PTO switch and showed obvious signs of melted plastic. Any suggestions? Thanks in advance!
 

·
Registered
Joined
·
9 Posts
Update to readers -

Old/current PTO clutch tested out at 0.5 ohms which it should be 3-10 ohms. This explains why the PTO switch has shorted and fried the PTO switch. I have a new PTO clutch and switch coming. The final results are pending. The old PTO clutch came off hard but it can be done with a breaker bar. Be careful not to round off the PTO clutch bolt like i did. I'll give a final report once I've tested it out.
 
1 - 8 of 8 Posts
Top