Green Tractor Talk banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2010 X300 with the Kawasaki 17hp motor, and 100hrs. on it. The motor will turn over but won't start. I replaced the fuel pump and I have checked the fuse block with them all being fine. I checked the spark plugs and coils neither has a spark. That's as far as my mechanic ability goes. This is the first issue I have had. Any suggestions?
 

·
Registered
Joined
·
1,465 Posts
No specific suggestions to offer but here is some information that might help you isolate the issue. Most of the 'smarts' on these tractors are on a single board -- replacement is pretty simple but somewhat expensive...

View attachment x300 series electrical from TM2308.pdf

The AM141075 control module/instrument panel assembly costs $67.64 at our site sponsor GreenFarmParts as seen here:http://www.greenfarmparts.com/John-Deere-Electronic-Control-Unit-AM141075-p/am141075.htm

Let us know what you find and good luck,

Chuck
 

·
Registered
Joined
·
144 Posts
its probably the computer. Mine went. you can test this by taking the electrical spade connectors off of both coils (solenoids). If it runs with both off buy yourself a new engine computer (ecu). i think it was 80 bucks
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
No specific suggestions to offer but here is some information that might help you isolate the issue. Most of the 'smarts' on these tractors are on a single board -- replacement is pretty simple but somewhat expensive...

View attachment 31630

The AM141075 control module/instrument panel assembly costs $67.64 at our site sponsor GreenFarmParts as seen here:John Deere Electronic Control Unit AM141075

Let us know what you find and good luck,

Chuck
Thanks a lot, i'll let you know.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
its probably the computer. Mine went. you can test this by taking the electrical spade connectors off of both coils (solenoids). If it runs with both off buy yourself a new engine computer (ecu). i think it was 80 bucks
I try the test, hopefully it isn't that after only three years. It's garage kept and never been rained on.
 
1 - 5 of 5 Posts
Top