Green Tractor Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My X324 bogged down in some tall weeds, PTO wouldn't engage so I stopped it and cleaned it out, made sure the blades turn freely. But now when I try to engage the PTO, I hear an electrical click; blades don't engage. Called the dealer. Asked me to check Youtube first then bring it in. Is there something wrong with the PTO clutch? How to troubleshoot that? Thanks!
 

·
Registered
Joined
·
393 Posts
I have no experience with your tractor/deck model, but would suggest making sure the belt is completely on inside the deck. Normally, with an electric clutch, engine not running (of course) there would be great resistance when trying the rotate the blades by hand. Hopefully the belt has jumped off one of the pulleys, idler, or a broken spring. Guess I should ask if the deck uses two belts or just one?

Can you get a helper to start the engine and flip the PTO switch while you are in a positively SAFE position to see if the PTO pulley is turning or not turning? If it doesn't turn with the engine running, it may have broken inside or sheared the key. A good "click" would usually indicate the electromagnet is good. Some clutches have an "air gap" adjustment that should be checked. Some are not adjustable.

Let us know what you find.

tommyhawk
 

·
Registered
Joined
·
192 Posts
As above. Check out Xtreme clutch and Taryl Fixes All on YouTube. With a set of pullers it’s a little over $100 if you need to do the PTO.
 
1 - 6 of 6 Posts
Top