Green Tractor Talk banner
1 - 3 of 3 Posts

·
Registered
2021 4044M
Joined
·
111 Posts
Discussion Starter · #1 ·
I bought a new set of OEM Deere mower blades for my X350 with the 48” deck. The old ones may be too bad to even be sharpened. But that’s a different issue.

Am I to safely assume the blades are balanced from the factory? I ask because the mower sounds very different while it’s running. There is no discernible vibration but there is sort of a rhythmic growl while the blades are engaged.

All three blades are installed with the cutting edge in the proper orientation, the washer is in place, and are torqued to spec.

Should they be installed with all 3 blades pointing the same direction, like all aligned perpendicular to the direction of travel? I confess that I did not check anything like that when removing the old blades.

Maybe it always made this sound and I just didn’t notice it, but I would think that I would have.

Thanks for any thoughts or advice.
 

·
Registered
Joined
·
13,582 Posts
How clean was the deck. Mine growls when clogged with wet clippings.
 

·
Registered
2021 4044M
Joined
·
111 Posts
Discussion Starter · #3 ·
Good thought. I spent the better part of an hour scraping away all of the accumulated crud under there before I installed the new blades.

One thing I didn't mention is that I only used it in mulching mode today. I’ll have to try tomorrow with the chute open.

But the grass was extremely dry so I don’t think there was any buildup today.
 
  • Like
Reactions: jmb6420
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top