Green Tractor Talk banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just installed a mulch kit from JD for an X350
As soon as the blades are engaged it vibrates and disengages.
I haven't mowed anything with the new blades so nothing has been hit or damaged.

I took the deck off and rechecked the installation and made sure the blades are installed
correctly. No loose bolts or nuts, belt pathway is correct and the tension seems good.

Any ideas?

Thanks
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Figured out the problem with vibrating

I just installed a mulch kit from JD for an X350
As soon as the blades are engaged it vibrates and disengages.
I haven't mowed anything with the new blades so nothing has been hit or damaged.

I took the deck off and rechecked the installation and made sure the blades are installed
correctly. No loose bolts or nuts, belt pathway is correct and the tension seems good.

Any ideas?

Thanks

I took the mulch blades off and reinstalled the originals and the issue went away.
The mulch blades look OK but I'm going to weigh them and check the balance.
 

·
Premium Member
Joined
·
1,122 Posts
The mulch blades look OK but I'm going to weigh them and check the balance.[/QUOTE]

^^^^^^^^^ What he said . Check blade balance . ^^^^^^^^^^
:munch:
 

·
Registered
Joined
·
1 Posts
X350 Mulch Blade Vibrartion

I had the exact same problem. Added the JD mulch kit to my Accel 42 deck on my X350 yesterday. As soon as I started the deck there was significant vibration and then the deck would disengage. Eventually it would continue to run, but the vibration was awful. I put the original blades back on and the vibration stopped. I guess I will check the new blades for balance. Could JD have shipped a bunch of defective blades.
Let me know if you learn anything.
Thanks.
 

·
Registered
Joined
·
255 Posts
Either the blades are not balanced or they were not in the collar all the way and were not seated. I have done 20 or so mulch kits this year and have not had any blade issues yet.
 

·
Registered
Joined
·
3,228 Posts
What exactly is the difference between the stock & mulch blades? Could one be considerably lighter or heavier than the other?
How about posting some pictures?
I just put a set of knock off (forgot the name) gator blades on my X540 with a 54" deck. That deck never cut so good. At first I was worried about the 3 finger back side of the blade causing problems.
 

·
Registered
Joined
·
255 Posts
What exactly is the difference between the stock & mulch blades? Could one be considerably lighter or heavier than the other?
How about posting some pictures?
I just put a set of knock off (forgot the name) gator blades on my X540 with a 54" deck. That deck never cut so good. At first I was worried about the 3 finger back side of the blade causing problems.
The mulch blades look exactly the same but have a longer blade surface.
 

·
Registered
Joined
·
3,228 Posts
The mulch blades look exactly the same but have a longer blade surface.
Then I'm stumped. Don't think that alone would cause the problem. Not unless one end is drastically heavier than the other.
 
1 - 8 of 8 Posts
Top