Green Tractor Talk banner

1 - 11 of 11 Posts

·
Registered
Joined
·
264 Posts
Discussion Starter #1
There is a x540 for sale locally. 2009, 54" deck, 450 hours in great condition. Asking $5k but I suspect $4 to $4.5 would take it. Sounds like a good deal.

Thoughts?
 

·
Registered
Joined
·
280 Posts
yes, thats a good deal
 

·
Registered
Joined
·
264 Posts
Discussion Starter #3
Any thoughts as to what it is worth?
 

·
Registered
Joined
·
280 Posts
i would say 4 or so maybe 4500 but if you think about it thats 125 hours a year so pretty average so you know wasnt a commercial used one and the hour meter is correct
 

·
Registered
Joined
·
7 Posts
Being a X540 owner there a couple of things I would recommend to you. It smokes when you let it sit overnight and start it. Nothing I know of you can do about it. The engine just smokes on startup. Next, rough surge running. Until the engine warms up the blasted thing is going to surge up and down. I have changed fuel filters and cleaned /adjusted the carb to no avail. It is just going to surge up and down. I also recommend you go cut some bremuda grass with it. Mine gives a terrible and uneven cut even with deck leveling and new blades. I am thinking of trading my X540 for a brick then throwing the brick in the river so I can say I actually lost something.
 

·
Registered
Joined
·
280 Posts
your mower might just be a defected mower deck, have you consulted to your dealer about your troubles
 

·
Registered
Joined
·
2,160 Posts
Being a X540 owner there a couple of things I would recommend to you. It smokes when you let it sit overnight and start it. Nothing I know of you can do about it. The engine just smokes on startup. Next, rough surge running. Until the engine warms up the blasted thing is going to surge up and down. I have changed fuel filters and cleaned /adjusted the carb to no avail. It is just going to surge up and down. I also recommend you go cut some bremuda grass with it. Mine gives a terrible and uneven cut even with deck leveling and new blades. I am thinking of trading my X540 for a brick then throwing the brick in the river so I can say I actually lost something.
Sounds like you may have either a warped deck or bent spindle or spindle mount.Also ,I had a motorcycle doing the surging until warm problem...turned out to be the intake manifold wasnt sealing good until warmed up.RTV silicone around connection solved it.
 

·
Registered
Joined
·
264 Posts
Discussion Starter #8
Well I brought it home last night. I am happy to report that I am not experiencing any of the problems listed above. No puff of smoke on start up, no rough idle/surging and the cut is as even as I have ever seen.

The power is also impressive. I think I am going to like this almost as much as my 2520. :lol:
 

·
Registered
Joined
·
264 Posts
Discussion Starter #10 (Edited)
Coming soon. A thorough going over and general waxing are in order. It was well looked after mechanically but cosmetically ..... well let's just say it was more than a bit lacking. Nothing serious. Just neglect in that area. I am a bit picky that way so I will compound it (almost done actually), use a bit of touch up paint and then a waxing. I know, sounds sick but if its worth buying, its worth looking after.
 

·
Premium Member
Joined
·
6,593 Posts
I know, sounds sick but if its worth buying, its worth looking after.
Yeah, and we all are infected. :yahoo:
 
1 - 11 of 11 Posts
Top