Green Tractor Talk banner

1 - 3 of 3 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1 (Edited)
I just got a 2017 X580 used with 6.6 hours. I was looking at the reservoir for the transaxle I couldnt make out there was any oil in it so I took off the cap and there was like a sponge in the opening , is that suppose to be there ? I dont have the owners manual yet the previous owner was given the wrong manual ( 300 series ) so he had to order one and is going to be mail to me. So with that said I think the trans axle is low can some tell me what oil I need to get from the dealer. I have not used it yet I want to get this squared away first. Thanks V

My bad, I found a manual online so that helps.
 

·
Premium Member
Joined
·
10,694 Posts
The foam is supposed to be there. It acts like a filter to keep dirt out of the filler hole. The fluid typically used in these transaxles is John Deere Low Viscosity Hy-Gard. The manual states it is okay to use regular Hy-Gard if your climate warrants it. There is a chart in the manual showing the ambient temperatures for each fluid type.

Be very careful not to over fill the reservoir. It only takes a few ounces to go from ADD to FULL. Let the tractor sit over night before checking the fluid level and make sure it's sitting on a level surface.




 

·
Registered
Joined
·
39 Posts
My X570 has a leak in the reservoir and dropped the fluid on the trans axle. I took it to the dealer to be fixed under warranty. So maybe keep an eye on it in case there is an issue with it.


Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
Top