Green Tractor Talk banner

1 - 9 of 9 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter #1
I was preparing my tractor mowing season. I removed the snow blade, sharpened the blades, lubs everything, and went to mount mower under tractor. The mower lift will not lower. The 3pt hitch goes up and down but mower arms barely move. Any ideas before I take it to the dealer? The cam arm rotates back and forth as I raise/lower the lever. I opened and closed the diverter valve a few times. Nothing.
 

·
Registered
Joined
·
554 Posts
I was preparing my tractor mowing season. I removed the snow blade, sharpened the blades, lubs everything, and went to mount mower under tractor. The mower lift will not lower. The 3pt hitch goes up and down but mower arms barely move. Any ideas before I take it to the dealer? The cam arm rotates back and forth as I raise/lower the lever. I opened and closed the diverter valve a few times. Nothing.
Did you make sure the mower deck height adjustment knob is lowered all the way to bottom-most position?

I've also been guilty of using the lever that raises and lowers the plow blade and thinking it should lower the deck arms. It is the other lever that handles up/down on the mower.

Otherwise, I'd still double check the diverter valve is turned the correct way.

These are all things that I've experienced first hand, haha! :lol:
 

·
Registered
Joined
·
1,067 Posts
I'd definitely check the lockout valve and the deck height knob. I have a quarter turn lockout valve and had this issue the first time I switched to the mower deck after plowing snow. The quarter turn valve wasn't letting fluid through and I discovered I had put the handle in a position that was closed at both settings. I took It off and played with it and figured it out and now all is well.
 

·
Registered
Joined
·
3,877 Posts
Did you make sure the mower deck height adjustment knob is lowered all the way to bottom-most position?

I've also been guilty of using the lever that raises and lowers the plow blade and thinking it should lower the deck arms. It is the other lever that handles up/down on the mower.

Otherwise, I'd still double check the diverter valve is turned the correct way.

These are all things that I've experienced first hand, haha! :lol:
Check the bypass valve is open as stated above,also the arms at times hang up.I have to grab the arms and pull them down sometimes on my x595.
 

·
Registered
Joined
·
1,319 Posts
All good suggestions. Could be the latch still latched, the diverter valve in wrong position or the arms just sticky. Without any weight on them they might not want to come down after being in one position for a while. If that's the case then lower the 3pt arms all the way, shut off the tractor and get under there to try to pull them down manually.

Rob
 

·
Registered
Joined
·
342 Posts
Discussion Starter #7
Well I finally had time to get out there and fool with it after a long work week. The lift height was set to the lowest setting. So that wasn't it. Though I have made that mistake before on my bigger tractor. This time I just keep opening and closing the bypass and exercising the hyrdraulics. After several times, it finally starting working! I hope it's not a sign of a future problem. Thank for the suggestions.
 

·
Registered
Joined
·
1,067 Posts
Well I finally had time to get out there and fool with it after a long work week. The lift height was set to the lowest setting. So that wasn't it. Though I have made that mistake before on my bigger tractor. This time I just keep opening and closing the bypass and exercising the hyrdraulics. After several times, it finally starting working! I hope it's not a sign of a future problem. Thank for the suggestions.
Thanks for the update. Which type lockout do you have?
 

·
Registered
Joined
·
392 Posts
Did you make sure the mower deck height adjustment knob is lowered all the way to bottom-most position?
Haha this right here. About 2 weeks ago it took me roughly 30 minutes and 2 beers to put my auto connect deck on my X758..... getting more and more pissed off, as I was getting ready to hook up the trailer to the pick up, it hit me.

Sent from my SM-N950U using Tapatalk
 
1 - 9 of 9 Posts
Top