john deere 4020 hydraulic issue
Results 1 to 2 of 2

Thread: john deere 4020 hydraulic issue

  1. Top | #1

    Join Date
    Sep 2017
    Last Online
    09-05-2017 @ 09:22 PM
    Location
    nocona tx
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    john deere 4020 hydraulic issue

    i have a 1966 John Deere 4020 PS diesel the tractro starts easy and runs well. the hydraulics work in D only. if i select L or LD no hydraulics at all but in D the 3 point raises and lowers quickly. the FEL works if i manipulate the levers in a specific sequence (eg scv lever forward + loader lever back = loader raises , scv lever back + loader lever forward = loader lowers). Power steering and brakes perform flawless no trouble whatsoever. trans temp rises after 3 hours or so of brushhogging

  2. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

  3. Top | #2

    Join Date
    Oct 2014
    Last Online
    Today @ 03:54 PM
    Location
    Coyote Flats,Texas
    Posts
    1,644
    Thanks
    15
    Thanked 283 Times in 254 Posts
    Welcome to GTT
    L/D mechanism needs to be adjusted following the steps outlined in JD tech manual. It also sounds as if SCV needs attention & it's valves set to spec's as FEL should operate correctly with scv lever in either forward or rearward position but not both positions. I will suggest to attach loader hyd's directly to tractor hyd's freeing scv's for other purposes.

  4. Remove Advertisements
    GreenTractorTalk.com
    Advertisements
     

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •